Can't send

All LINUX related questions (Installation & usage)

Moderator: marcus

Can't send

Postby ocgltd » Sat 4. Sep 2010, 15:25

I have an IRTrans Ethernet running great for receiving IR. My MythTV receives codes fine from the IrTrans (using lirc emulation)

I know want to SEND ir codes through the IRTrans Ethernet. If I issue a command like the following from the bash prompt:
irsend -d /dev/lircd send_once mythtv up

Then the prompt returns (no errors), but nothing is sent! I have tried two different IR transmitters plugged into the IR transmitter jack (next to Ethernet jack), but nothing comes out! (I can tell because my Xantech unit flashes whenever any IR is detected)

What am I doing wrong?


(I have /var/run/lirc/lircd mapped to /dev/lircd in case that matters)
Posts: 40
Joined: Tue 30. Dec 2008, 03:34

Re: Can't send

Postby ocgltd » Sat 4. Sep 2010, 15:38

It just occured to me to check the irtrans log and I see this

2010-09-04 11:36:06.010 Local Socket connection request
2010-09-04 11:36:06.010 Local Client 3 accepted on 12
2010-09-04 11:36:06.010 LIRC Command String: send_once mythtv up
2010-09-04 11:36:06.010 LIRC SEND_ONCE Rem: mythtv Key: up

So is this a hardware problem?
1. I've tried 2 different IR I doubt it's that.
2. I am plugging into the 3.5mm connection on the side of the unit with the POWER and ETHERNET connections.
3. Your manual says that the internal vs external IR tranmitters are addressed seperately, but the "irsend set_transmitters" command just returns an error and the log shows:
2010-09-04 12:07:47.387 LIRC Command String: set_transmitters 1
2010-09-04 12:07:47.387 Unknown LIRC Command received: set_transmitters

Is there a jumper I need to flip? Any ideas?
Posts: 40
Joined: Tue 30. Dec 2008, 03:34

Re: Can't send

Postby IRTrans » Sun 5. Sep 2010, 20:16

selecting a transmitter through the LIRC socket is not supported. No idea why LIRC sending does not work for you.

However, you can simply use the IRTrans ASCII Client (irclient). It does support LED selection.

Here is the syntax:

irclient localhost mythtv up 1 0 EXT

(For External LEDs)

Posts: 2115
Joined: Mon 21. Apr 2008, 23:32

Re: Can't send

Postby ocgltd » Sun 5. Sep 2010, 21:02

Ok - I figured it out...the transmit function was disabled via the web page. I enabled SEND from the web page and now it works. Thanks
Posts: 40
Joined: Tue 30. Dec 2008, 03:34

Return to LINUX

Who is online

Users browsing this forum: No registered users and 6 guests