IRTrans Wifi macht kein DHCP in Ubiquiti Netzwerkumgebung

Forum zu Hardwarefragen zum IRTrans System

Moderator: marcus

IRTrans Wifi macht kein DHCP in Ubiquiti Netzwerkumgebung

Postby kieselbert » Fri 9. Jun 2017, 07:10

Hallo zusammen,

ich habe meine Fritzbox gegen Hardware aus dem Hause Ubiquiti ausgetauscht. Hat alles reibungslos funktioniert, auch die Wlan-Geräte hängen am neuen AP (UniFi AP AC PRO). Nur der IRTrans mag das neue Wlan nicht. Ich habe diverse Einstellungen durchprobiert, aber keine Verbindung zwischen IRTrans und dem AP aufbauen können.

Fehlermeldung IRTrans:
"Error 9 Fehler beim Verbindungsaufbau"

Fehlermeldung AP:

Code: Select all
<30>1 2017-06-09T08:53:05+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 74:68:6f:6d:65:00 IEEE 802.11: associated
<30>1 2017-06-09T08:53:05+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 74:68:6f:6d:65:00 WPA: received EAPOL-Key msg 4/4 in invalid state (7) - dropped
<14>1 2017-06-09T08:53:05+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 14839 - - libubnt[14839]: wevent.ubnt_custom_event(): EVENT_STA_JOIN ath1: 74:68:6f:6d:65:00 / 2
<4>1 2017-06-09T08:53:05+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") kernel - - - kernel: [ 7809.770000] ieee80211_ioctl_set_ratelimit: node with aid 2 and mac 74:68:6f:6d:65:00 has been tagged non rate-limiting
<30>1 2017-06-09T08:53:06+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 74:68:6f:6d:65:00 WPA: received EAPOL-Key msg 4/4 in invalid state (7) - dropped
<30>1 2017-06-09T08:53:07+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 74:68:6f:6d:65:00 WPA: received EAPOL-Key msg 4/4 in invalid state (7) - dropped
<30>1 2017-06-09T08:53:08+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 74:68:6f:6d:65:00 WPA: received EAPOL-Key msg 4/4 in invalid state (7) - dropped
<11>1 2017-06-09T08:53:09+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 14839 - - libubnt[14839]: dpi.dpi_stainfo_notify(): dpi not enable
<14>1 2017-06-09T08:53:09+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 14839 - - libubnt[14839]: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath1: 74:68:6f:6d:65:00 / 2
<30>1 2017-06-09T08:53:14+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 74:68:6f:6d:65:00 IEEE 802.11: deauthenticated due to local deauth request


In der IRTrans-Config kann man ja nicht viel konfigurieren außer seinen PreShared-Key zu hinterlegen. Die WPA-Settings auf dem AP hab ich schon in allen Varianten durchprobiert (WPA2 TKIP; WPA2 AES_CCMP). Hat jemand eine Idee was ich da noch machen kann?
Last edited by kieselbert on Mon 12. Jun 2017, 14:35, edited 1 time in total.
kieselbert
 
Posts: 7
Joined: Wed 3. Aug 2011, 11:29

Re: IRTrans Wifi keine Verbindung zu Ubiquiti AccessPoint

Postby kieselbert » Fri 9. Jun 2017, 07:46

OK, ich habe nun im Forum gelesen dass das WPA-Passwort max. 31 Zeichen lang sein darf (meins hatte 34). Jetzt hat es nur noch 29 Zeichen ;) .
Leider löst das mein Problem immer noch nicht.

Neue Fehlermeldung IRTrans:
"Error 10 Fehler bei der Übergabe der IP Parameter"

Logeinträge AP:

Code: Select all
<30>1 2017-06-09T09:40:18+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 IEEE 802.11: associated
<30>1 2017-06-09T09:40:19+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 RADIUS: starting accounting session 593A4D08-00000018
<30>1 2017-06-09T09:40:19+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 WPA: pairwise key handshake completed (RSN)
<30>1 2017-06-09T09:41:30+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 IEEE 802.11: associated
<14>1 2017-06-09T09:41:30+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 5314 - - libubnt[5314]: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath1: 00:23:a7:00:86:c6 / 1
<30>1 2017-06-09T09:41:30+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 RADIUS: starting accounting session 593A4D08-00000019
<30>1 2017-06-09T09:41:30+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 WPA: pairwise key handshake completed (RSN)
<14>1 2017-06-09T09:41:30+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 5314 - - libubnt[5314]: wevent.ubnt_custom_event(): EVENT_STA_JOIN ath1: 00:23:a7:00:86:c6 / 1
<30>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 IEEE 802.11: associated
<11>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 5314 - - libubnt[5314]: dpi.dpi_stainfo_notify(): dpi not enable
<14>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 5314 - - libubnt[5314]: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath1: 00:23:a7:00:86:c6 / 1
<11>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 5314 - - libubnt[5314]: dpi.dpi_stainfo_notify(): dpi not enable
<30>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 RADIUS: starting accounting session 593A4D08-0000001A
<30>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") hostapd - - - hostapd: ath1: STA 00:23:a7:00:86:c6 WPA: pairwise key handshake completed (RSN)
<14>1 2017-06-09T09:42:42+02:00 ("U7PG2,802aa8d3cfc2,v3.7.58.6385") libubnt 5314 - - libubnt[5314]: wevent.ubnt_custom_event(): EVENT_STA_JOIN ath1: 00:23:a7:00:86:c6 / 1

Habe neben DHCP auch eine statische IP ausprobiert, aber ebenfalls keinen Zugriff erhalten.
Anmerkung zum Log:
Die MAC hat sich zu vorher geändert. Jetzt ist es die, die auch auf das Gerät aufgedruckt ist.
kieselbert
 
Posts: 7
Joined: Wed 3. Aug 2011, 11:29

Re: IRTrans Wifi keine Verbindung zu Ubiquiti AccessPoint

Postby kieselbert » Mon 12. Jun 2017, 14:13

Hm, also ich weiß nicht wie ich es beschreiben soll, aber der IRTrans verhält sich schon etwas eigenartig im Netzwerk. :roll:
Ich habe nun schon einige Stunden damit zugebracht Tcpdumps auf allen Komponenten zu zu analysieren. Erst bin ich der Frage nachgegangen, was machen alle anderen Komponenten bei DHCP anders, weil die ja problemlos eine Adresse beziehen können. Jetzt stehe ich natürlich zwischen den Stühlen (Hersteller).
Auf der einen Seite ging der IRTrans ja vorher mit der Fritzbox 7490 (mit der 7390 gabs auch Probleme, siehe meine älteren Posts), also könnte man sagen auf Seite von IRTrans ist alles ok und der Hersteller Ubiquiti hat da irgendein Problem. Auf der anderen Seite kann man auch sagen das ich knapp 35 Wlan Geräte problemlos in der neuen Umgebung betreiben kann und die sich alle brav ihre IP besorgen.
Das Thema habe ich im Ubiquiti-Forum mal kurz adressiert --> https://community.ubnt.com/t5/UniFi-Routing-Switching/DHCP-Problem-Device-is-stucking-in-quot-Discover-quot/m-p/1959470#U1959470

Ansonsten habe ich auch noch versucht dem IRTrans manuell eine IP zu verpassen, ab da wurde es dann ganz komisch. Mit fester IP kann ich den IRTrans tatsächlich anpingen und auch die Weboberfläche erreichen. Ich dachte schon....naja kein DHCP, Pech... dann halt eine feste IP...Problem gelöst.
Leider ist die IRTrans-Server Software aber nicht dazu zu bewegen zum Gerät eine Verbindung aufzubauen (Error opening COM/USB Port/LAN Device). Was da im Detail schief läuft kann ich nur erahnen. Ich sehe im Dump (auf dem AP), wie die Kommunikation vom Gateway (192.168.6.1) zum IRTrans (192.168.6.3) auf Port 21000 aufgebaut werden soll. Aber das komische an dem folgenden Dump ist.....es dürfte ihn überhaupt nicht geben. Sowohl der Rechner mit dem IRTrans Server, als auch der IRTrans befinden sich im selben Subnetz und VLAN. Es gibt also auch keinen Grund über den Router zu gehen. Vielleicht kurz zur Erklärung, der Accesspoint (mit dem der IRTrans verbunden ist) hängt an einem Switch und an dem hängt auch der Rechner. An den Switch ist ein SecurityGateway/Router ebenso angeschlossen. Ich sehe auch wie der Rechner Arp-Anfragen für den IRTrans rausschickt, aber die Antwort nicht in seine Arp-Table aufnimmt (warum auch immer). Daher läuft die Kommunikation immer über den Router. Mehr fällt mir zum Thema nicht mehr ein :?

tcpdump vom Accesspoint:
Code: Select all
15:54:55.207842 IP 192.168.6.1.62536 > 192.168.6.3.21000: UDP, length 76
15:54:55.226905 IP 192.168.6.3.21000 > 192.168.6.1.21000: UDP, length 78
15:54:55.227262 IP 192.168.6.1 > 192.168.6.3: ICMP 192.168.6.1 udp port 21000 unreachable, length 114
15:54:59.243482 IP 192.168.6.1.62536 > 192.168.6.3.21000: UDP, length 76
15:54:59.260155 IP 192.168.6.3.21000 > 192.168.6.1.21000: UDP, length 78
15:54:59.260459 IP 192.168.6.1 > 192.168.6.3: ICMP 192.168.6.1 udp port 21000 unreachable, length 114
15:55:00.209266 ARP, Request who-has 192.168.6.3 tell 192.168.6.1, length 42
15:55:00.210909 ARP, Reply 192.168.6.3 is-at 00:23:a7:00:86:c6 (oui Unknown), length 44


tcpdump vom Router (james-PC = Rechner mit IRServer):
Code: Select all
16:30:04.335194 IP james-PC.57545 > 192.168.6.3.21000: UDP, length 76
16:30:04.351460 IP 192.168.6.3.21000 > 192.168.6.1.21000: UDP, length 78
16:30:04.706550 ARP, Request who-has 192.168.6.3 tell james-PC, length 46
16:30:09.339126 ARP, Reply 192.168.6.3 is-at 00:23:a7:00:86:c6 (oui Unknown), length 44


- AP und Rechner hängen im gleichen Subnetz & VLAN
192.168.6.3 = IRTrans
192.168.6.1 = Gateway/Router
192.168.6.6 aka james = PC mit IRServer
kieselbert
 
Posts: 7
Joined: Wed 3. Aug 2011, 11:29

Re: IRTrans Wifi macht kein DHCP in Ubiquiti Netzwerkumgebun

Postby kieselbert » Tue 20. Jun 2017, 18:48

Servus,

Ich hatte nun den Hersteller-Support mit meinem Problem "belästigt" und muss schon sagen, die Jungs in Kalifornien sind da recht fit ;-).
Kurz gesagt, ich habe eine Lösung für mein Problem....aber leider nicht wirklich verstanden was da beim IRTrans so anders läuft, als bei allen anderen Geräten. Vielleicht macht ja jemand einen Erklärungsversuch wenn ich gleich erzähle an was es lag ;) .

Es gibt beim Unifi Security Gateway (was auch DHCP-Server spielt) die Möglichkeit Multicast und Broadcast aus dem LAN Richtung WAN zu blocken (siehe Anhang). Solange diese Einstellung aktiv ist (und das habe ich für alle Subnetze so eingestellt) schafft es der IRTrans nicht sich per DHCP eine IP zu ziehen. Darüber hinaus funktioniert auch die Kommunikation mit statischer IP nicht. Ich habe versucht den IRTrans in die Ausnahmeliste hinzuzufügen, klappt leider nicht. Nur wenn ich die Funktion komplett abschalte kann ich den IRTrans benutzen. Was das Gerät da letztendlich genau tut und warum es diese "Freiheit" benötigt.....tja das wäre nun die interessante Frage.
Attachments
ubiquiti_irtrans.jpg
ubiquiti_irtrans.jpg (69.61 KiB) Viewed 8132 times
kieselbert
 
Posts: 7
Joined: Wed 3. Aug 2011, 11:29


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

cron